Yoast SEO 3.2

Yoast SEO 3.2

April 20th, 2016 – 68 Comments

Today we’ve pushed out Yoast SEO 3.2. This release’s most notable feature is the addition of a help center to every settings page. You’ll remember we released tutorial videos a while back. These videos are now available right where you’d need them: on the tab that each video discusses. Other changes include accessibility improvements and tons of bug fixes. Last but not least, we have Social Previews in Yoast SEO Premium.

Accessibility changes

As you’ll have noticed we hired Andrea Fercia a while back. Andrea has been working hard on improving the accessibility of Yoast SEO. Some of the changes he’s made are visible and useful to everyone. Our new toggles were improved, as well as our inline help, which now looks like this:

Improved inline help functionality

Help center

We released our tutorial videos a few weeks ago. After that, we thought: how can we use these videos most effectively? The answer was rather simple: put the videos on the tab they talk about. The “most WordPress way” would have been to put them in the help tab. Unfortunately, nobody, ever, seems to be able to find that tab, so we’ve made it far more visible:

Screenshot of the new help center, a purple bar in the admin page with a help icon and the text "Help center"

When you click it, it expands and contains the video for that tab:

A screenshot of the help center in its expanded state, with a video explaining the features on the current tab.

Premium: Social previews

In Yoast SEO Premium, we added a cool new social previews feature. Much like the snippet preview it shows you what your post will look like when shared on Facebook and Twitter. If you don’t have premium yet, now might be a good time to get it!

Social Previews in Yoast SEO Premium

Removed functionality

We’ve removed the “hide” features we had, for hiding RSS feeds and a few other things. There simply is no real SEO benefit to these features. On top of that WordPress is adding more and different things to the <head> all the time and deleting them can lead to issues.

Google-

Google+ is dwindling, so we were already discussing its fate in our plugin. The Google+ metadata on posts was conflicting more and more with Facebook. Facebook was picking up Google+ images over Facebook OpenGraph images. These factors combined made us decide to remove the Google+ functionality from the plugin.

Under the hood

We’ve made a ton more changes under the hood this release. XML sitemaps received a lot of care, as well as the content analysis. We added some new features you might want to use in your theme with the yoast_get_primary_term() and yoast_get_primary_term_id() functions.

Community

Eleven contributors outside of Yoast contributed to this release with patches. This brings the total number of contributors to the plugin to 112, a number we’re very proud of!

Go try it, and let us know in the comments what you think!


68 Responses to Yoast SEO 3.2

  1. Hitesh bhasin
    By Hitesh bhasin on 1 May, 2016

    My traffic has dropped since 28th april. prior to that i had installed AMP and it had suddenly increased like anything. I searched and searched and finally it clicked me that i had upgraded Yoast plugin the same date. Now the traffic is going on dropping and i am on May 1. Any idea how this can be happening? My url is http://www.marketing91.com I dont think it is a partial update. Should i export my settings, delete and reinstall yoast and then try again?

    • Hitesh bhasin
      By Hitesh bhasin on 2 May, 2016

      I will like to retract my statement. The problem was not due to yoast. I had installed Monsterinsights on 17th of the month. I removed the plugin the same day that i updated yoast. Monster insights was a 2nd implementation of google analytics, causing an artificial hike in the traffic. Hence 28th showed a massive drop. A clarification was necessary so that my comment does not fall negative on yoast plugin

  2. Paul
    By Paul on 30 April, 2016

    Had to deactivate Yoast –
    I was getting lots of apache2 segmentation errors that consumed all the memory and them forced ubuntu to halt mysql.
    Conflicted with wordfence –
    i have everything upto date in ubuntu (apt-get upgrade) and all plugins and running latest wordpress.
    I installed swapfiles and modifed maxworkers to optimize memory – all failed
    everything points to yoast
    Anyonel else having wordfence yoast memory issues ???

  3. Shidartha
    By Shidartha on 30 April, 2016

    Hello there!

    I am still receiving the following messages every single time a click on “Pages” on my admin area:

    Notice: Undefined index: opengraph-title in /nas/content/live/*****/wp-content/plugins/wordpress-seo-premium/premium/classes/class-social-previews.php on line 135

    Notice: Undefined index: opengraph-description in /nas/content/live/*****/wp-content/plugins/wordpress-seo-premium/premium/classes/class-social-previews.php on line 136

    Notice: Undefined index: opengraph-image in /nas/content/live/*****/wp-content/plugins/wordpress-seo-premium/premium/classes/class-social-previews.php on line 137

    Notice: Undefined index: twitter-title in /nas/content/live/*****/wp-content/plugins/wordpress-seo-premium/premium/classes/class-social-previews.php on line 138

    Notice: Undefined index: twitter-description in /nas/content/live/*****/wp-content/plugins/wordpress-seo-premium/premium/classes/class-social-previews.php on line 139

    Notice: Undefined index: twitter-image in /nas/content/live/*****/wp-content/plugins/wordpress-seo-premium/premium/classes/class-social-previews.php on line 140

    I already completely uninstalled and reinstalled Yoast 3.2.4, purge WPEngine cache, but it didn’t helped.

    Note: If I deactivate Yoast, all messages are gone.

    Can you guys help me out?

  4. Rachel
    By Rachel on 28 April, 2016

    Your new update crashed my website and now I cannot get it back up. I need to know what I have to do to fix it. My website worked perfect until trying to install the update.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    • Joost de Valk
      By Joost de Valk on 28 April, 2016

      Hey Rachel,

      sounds like you have an incomplete update… Could you remove the plugin and reinstall it? That’ll normally fix the issue…

  5. Loreen
    By Loreen on 28 April, 2016

    I’ve updated the plugin but it keeps my wp dashboard keeps on saying there’s another update when there is not. Also, every few days the plugin keeps on asking me to update it, I do, and its successful but that extra update still hangs around…its weird like it’s on a merry go round and it cant get off. I’ve got 4 wp sites its doing the same thing too. is there any suggestions to this?

  6. Wouter Postma
    By Wouter Postma on 28 April, 2016

    Looks great!

    However, it looks like the focus keyword in the alt tag of my image is not being recognized. It says (in Dutch): “De afbeeldingen op deze pagina bevatten geen alt-attributen met het trefwoord.” – while the focus keyword is the same as the alt tag of the image on my page.

    Cheers,
    Wouter

    • Joost de Valk
      By Joost de Valk on 28 April, 2016

      Hey Wouter,

      we’ve identified the issue and a fix has been coded up. Next patch release will contain it :)

  7. Paul Yates
    By Paul Yates on 28 April, 2016

    I bought Yoast SEO Premium on Monday 11th April (two and a half weeks ago), because I had a big problem with my page edit grinding to a halt (Divi). I thought that becoming a Premium customer would at least get me some urgent support.
    Not a bit of it!
    I had to wait 6 days before I received a response, which was effectively that they did not know how to fix the problem (which has been widely reported by Yoast users since last November), and that instead they recommended I should switch off Yoast so that it did not update in realtime when I was editing a page. I did this and every single Yoast analysis dissappeared from every single page, which is completely useless.
    So I reported this and the next thing is that last Thursday Yoast support asked for access to my dashboard.
    I had another issue to resolve which meant that I did not reply until Saturday.
    Also, in the meantime, Yoast Premium 3.2 was launched, but when I clicked update in the plugins section of my dashboard, nothing happens. The Yoast plugin just will not update to the latest version.
    So I mentioned this when I responded on Saturday.
    Guess what? I have had no reply.
    I have sent reminder emails to them, sent messages from the question mark in SEO on my dashboard, I have tried contacting them via the contact facility on their website.
    And . . . . . . . .nothing! just complete blank.
    So this is what you get for your Premium Licence. Just lack of respect and lack of response.
    The Yoast plugin has not worked properly on my site since the day installed the free version, four months ago.
    I specifically asked Yoast support to turn around my jaundiced view of their product and support by sorting this out quickly and effectively.
    So what have they done? Just the opposite.
    Is this the psychology of how to win good customers and how to keep them satisfied?
    It beggars belief!

    • Taco Verdonschot
      By Taco Verdonschot on 28 April, 2016

      Apologies for the delay and your overall experience so far. We agree with you, this is not what you should expect from Yoast support.

      We’ve replied to your email and will continue to work with you to resolve the issues you encountered.

  8. Lisa
    By Lisa on 27 April, 2016

    Hoi,

    Ik heb problemen met de nieuwe update 3.2. Sinds ik deze update geïnstalleerd heb doet de contentanalyse het niet meer. Ik zie dus een rood bolletje bij SEO staan. De andere doen het nog wel.

    Hoe kan ik dit probleem oplossen?

  9. David
    By David on 27 April, 2016

    It is a good plugin.
    I really like a nice feature (Premium: Social previews) .
    thanks,

  10. Cristena
    By Cristena on 27 April, 2016

    Same thing for myself and all my friends and clients. Everything is just blank none of the videos are showing up. I came here to even watch your main video. I am so sorry I tell everyone to use yoast because it is the best and now everyone is yelling at me. Please fix this. Everyone I have turned on to yoast is saying they can’t live without it and i am scared to tell them to spend the money to go to premium if the basic doesn’t even work now. I can give screen shots if that will help.

    • Joost de Valk
      By Joost de Valk on 28 April, 2016

      Hey Cristena, screenshots are nice but errors from an error log would be even more helpful…

  11. Rogier
    By Rogier on 26 April, 2016

    Hello,

    After updating to 3.2 my backend is white! I have only the navigation bar on the right. Disabling the Yoast Premium plugin brings back the administrator again. Any solution??

    Best Rogier

    • Rogier
      By Rogier on 26 April, 2016

      Oh, and i tried to disable all other plugins but that didn’t work…

      • Joost de Valk
        By Joost de Valk on 28 April, 2016

        Hey Rogier,

        could you delete the plugin entirely and reinstall it, see if that helps?

  12. Chris
    By Chris on 26 April, 2016

    Hi,
    I have updated to 3.2.3 and my site now comes up with –
    Fatal error: Class ‘WPSEO_OnPage’ not found in D:Hosting12175913htmlwp-contentpluginswordpress-seowp-seo-main.php on line 367

    I’m not able to access my dashboard to deactivate the plugin either. Can you please let me know what I need to do to get my site back?

    Thanks,

    • Joost de Valk
      By Joost de Valk on 28 April, 2016

      Hey Chris,

      remove the plugin and reinstall it, sounds like you suffered from an incomplete update.

  13. Helgesen
    By Helgesen on 25 April, 2016

    My site also went “white” seems to be a problem between Jetpack and Yoast. I disable Jetpack and the site works, but when I enable Jetpack again the site get the “White screen of death”

    • Joost de Valk
      By Joost de Valk on 25 April, 2016

      So… Jetpack causes an error, update that maybe? :)

  14. Omar Al-Ansari
    By Omar Al-Ansari on 24 April, 2016

    It seems that the message that pops up saying “Yoast SEO has been updated to version 3.2.3. Click here to find out what’s new!” does not disappear. It keeps showing up on every single page on the admin area. This is becoming annoying and it would be nice if it gets fixed. Latest update does not seem to fix it.

    • Taco Verdonschot
      By Taco Verdonschot on 28 April, 2016

      This should be fixed in Yoast SEO 3.2.4.
      Sorry for the inconvenience.

      • Omar Al-Ansari
        By Omar Al-Ansari on 28 April, 2016

        I just updated to 3.2.4 and it does not seem to be fixed?

        • Joost de Valk
          By Joost de Valk on 28 April, 2016

          Hey Omar,

          kind of sad to hear that. Do you have any object cache or other cache running? If so, could you try clearing that?

          • Omar Al-Ansari
            By Omar Al-Ansari on 29 April, 2016

            Hey Joost,

            I already tried that. I have w3 total cache installed. I cleared the cache and I even tried deactivating the plugin. However I still get the message.

  15. Kiril
    By Kiril on 24 April, 2016

    Why in this version do not work the options to hide RSD Links, WLW Manifest Links and Shortlinks?

    • Joost de Valk
      By Joost de Valk on 24 April, 2016

      Because we removed those features, as I said in the post above :)

  16. Gio
    By Gio on 23 April, 2016

    – Snippets does not work, traffic lights not working.
    – Slow site with active Yoast
    – Switch from “view” to “text” does not work in the articles.
    – Pull-down menu (wp-admin) does not work with active Yoast.

    What happens?

  17. Joynul Abedin
    By Joynul Abedin on 22 April, 2016

    How can i fix stop word . I have checked permalink . I have faced this problem after updating my Yoast SEO plugin . Please let me know .

  18. Jason
    By Jason on 22 April, 2016

    Most of my appthemes based sites dashboard is breaking at top. And I have one long time wish for upcoming updates in Yoast. I want to combine Title from Yoast settings + Custom Post Seo title.
    So, if my common custom post title is Hello I m common and whereas my post seo title is “You got me custom”, I need a option to combine both to look like “Hello I m common You got me Custom”

  19. Halil
    By Halil on 22 April, 2016

    The new version 3.2.3 does not work well
    Text editor does not work
    Custom Structure does not work

  20. Matt
    By Matt on 21 April, 2016

    The successful update notification won’t go away, despite clicking on the “x.” This is with the latest version of both the plugin and WordPress.

  21. Kris Gunnars
    By Kris Gunnars on 21 April, 2016

    Hello Yoast team,

    I have one problem with the 3.2 version of your awesome plugin.

    For some reason, the post-sitemap.xml file is showing my homepage. Not only once, but twice: https://authoritynutrition.com/post-sitemap.xml.

    It also shows once in the page-sitemap.xml, which is normal, but I don’t think it should be showing in the post sitemap, let alone twice.

    Any idea how to fix this?

    Thanks,
    Kris

  22. Joe
    By Joe on 21 April, 2016

    3.2 Hangs the WP dashboard. I reverted back to 3.1.2, dashboard is back.

    • Leftie
      By Leftie on 24 April, 2016

      How did you do that? I have the same issue and I don’t know what to do to revert it back to 3.1.2….
      Thank you!

  23. Nathan
    By Nathan on 21 April, 2016

    Unfortunately having the same Permalink issue. All permalink are not working properly except for the home page. 404 errors on all pages after the update. If I switch to numbered permalink the pages load but I do not want to use numbers for the permalink. Strange. Trying to back up to previous version now and hoping not to lose everything.

    • erika
      By erika on 27 April, 2016

      Same issue here. A few minutes after updating Yoast SEO, all pages and posts turned 404, while the homepage still worked. I’ve deactivated and instantly the pages load as expected.

  24. Theo
    By Theo on 21 April, 2016

    Works fine for me thank you, just wondering about G+ dwindling.

  25. Ananda
    By Ananda on 21 April, 2016

    After updating 3.2.1 I am facing problem with my site. I can’t edit any page or post after updating yoast seo. Can you tell me why I am facing this types of problem.
    And can you tell me How can I back 3.2 version. Is it possible ?

  26. Robert
    By Robert on 21 April, 2016

    Hoi,

    Na de update werkt de Contentanalyse niet meer. Zie niets maar daar staan dus weet ook niet wat ik dan moet aanpassen om een goede SEO te krijgen :( Hoop dat je me kan helpen.

    • Fabianne
      By Fabianne on 21 April, 2016

      Hier helaas exact hetzelfde probleem! Het focus keyword werkt ook niet meer. Ik hoop dat er snel een oplossing voor komt.

      • Joost de Valk
        By Joost de Valk on 21 April, 2016

        We hebben het probleem gevonden! Door een fout in de Nederlandse vertaling (ja… echt!) komt er een % te weinig in het vertaalbestand en dat levert een error op. Er komt vandaag een update met een fix!

        • Lisa
          By Lisa on 28 April, 2016

          Bij mij werkt het nog steeds niet :(

        • Fabianne
          By Fabianne on 22 April, 2016

          Heel fijn, hartstikke bedankt!

        • Antoinette de Fouw
          By Antoinette de Fouw on 21 April, 2016

          Welke versie wordt dat dan?

          • Antoinette de Fouw
            By Antoinette de Fouw on 22 April, 2016

            3.2.3. has it working like a charm again :)

  27. porotikos
    By porotikos on 21 April, 2016

    i read all comments. mine hasnt got activated even after numerous attempts…

  28. Kim
    By Kim on 21 April, 2016

    Ok, super weird. I just randomly decided to attempt to activate it again, and it just decided to activate. I guess the 4th time was the charm.

  29. Kim
    By Kim on 21 April, 2016

    I’ve run into a problem as well – when I first tried to update the plugin, it was giving me a line error that I forgot to copy and hang onto in the Yoast admin. So I deactivated it, deleted it and reinstalled it from the repo.

    This is a single site, with almost nothing on it since it’s only a week old. Our other single seems ok and our MU doesn’t appear to have any issues either.

    Got a different error –
    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Call to undefined method Yoast_Notification_Center::initialize_conditions() in /home/XXXXXXXXXX/public_html/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 333

  30. NgilerSEO
    By NgilerSEO on 21 April, 2016

    Thanks.
    This post was very useful for me.

  31. john
    By john on 21 April, 2016

    i renamed the plugin folder to restore my site because yoast crashed it. after that, yoast was disabled. i renamed the plugin folder to its original name, and now when i try to enable yoast, i get this error
    Warning: include(/home/idiaiter/public_html/wp-content/plugins/wordpress-seo/admin/class-yoast-notification-center.php) [function.include]: failed to open stream: No such file or directory in /home/idiaiter/public_html/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186

    any help is appreciated

  32. Matt Rinkerman
    By Matt Rinkerman on 20 April, 2016

    Could you direct me to someone who could answer this ? Why does Yoast tell me that my keyword is not in the first paragraph when it is and sometimes the first word.
    Thanks

  33. porotikos
    By porotikos on 20 April, 2016

    while attempting (3 times) to update the plugin, my site crashed. i got it back by renaming the wordpress seo plugin folder. i am sure you will find a fix soon. but please can you tell me what to do in order not to lose my old settings? i cant remember exactly what seo descriptions and titles i used in every page i have., cant do that from scratch. i have access to the old installation folder. what can i do in order to update to new version(once it is fixed) and also maintain old settings?where are they saved specifically? thank you

  34. john
    By john on 20 April, 2016

    crushed my site.oh bloody hell. how can i revert back and not lose ALL my settings? i am sure you will give us a solution. thank you

  35. krish pilles
    By krish pilles on 20 April, 2016

    Title don’t work how can we fix please let us know ?

  36. Dinamicostudio
    By Dinamicostudio on 20 April, 2016

    My title doesn’t work how can i fix them please help me .

  37. David
    By David on 20 April, 2016

    not working for me either –crashing the editor. is there an easy way to roll it back?

  38. gouriev
    By gouriev on 20 April, 2016

    After local 3.2 plugin update

    Fatal error: Call to undefined function wpseo_has_multiple_locations() in /home/gourievc/public_html/wp-content/plugins/wpseo-local/local-seo.php on line 104
    if ( wpseo_has_multiple_locations() ) {
    $widgets[] = ‘WPSEO_Storelocator_Form’;
    }

    • Joost de Valk
      By Joost de Valk on 20 April, 2016

      Hmm that’s not good, checking with our team.

  39. Dražen
    By Dražen on 20 April, 2016

    Hi, when I update Yoast SEO to version 3.2 my sitemap.xml is not visible anymore I get 404 error. Redirect from sitemap.xml to sitemap_index.xml is missing. Can you fix this in next version?

    • Joost de Valk
      By Joost de Valk on 20 April, 2016

      Hey Drazen,

      Can you go to settings ? permalinks and see if it works better after that?

      • Dražen
        By Dražen on 21 April, 2016

        No, I try to regenerate Permalink Settings and update to version 3.2.1 but still no changes!

  40. Romeo
    By Romeo on 20 April, 2016

    Hello support,

    New version 3.2 is not working well. Category select not working focus keyword option not working.

    • Joost de Valk
      By Joost de Valk on 20 April, 2016

      Hey Romeo,

      Not sure what could cause this. Can you see any errors in your JS console?

      • Antoinette de Fouw
        By Antoinette de Fouw on 21 April, 2016

        The console shows: wp-seo-post-scraper-320.min.js:4 (3) Uncaught [sprintf] huh?


Check out our must read articles about WordPress