Plugin Requirements

Like most software, Yoast SEO has specific requirements to be able to run properly. Here, we list those requirements.

Note: In addition to the general requirements below, we recommend running current versions of everything on your site. That means you should regularly update your WordPress core, application, themes, and plugins. Learn why here.

Table of contents

WordPress version
PHP version
Database management systems
Browser requirements
Requirements for Premium plugins

WordPress version 

Yoast SEO requires WordPress version 5.2 or higher.

PHP version

PHP is a scripting language used for web development. For Yoast SEO to run properly, you should have a PHP version of 5.6.20 or higher. 

In fact, we recommend the PHP version 7.3 or above. Before you upgrade to a higher PHP version, check if your WordPress site is ready for it. Read this help article to learn how to update your PHP version. 

Your PHP memory should be 256M or greater.

Database management systems

Yoast SEO requires: 

Note: Yoast SEO may work on legacy environments that do not meet the above requirements.

Browser requirements

To use our plugins in the admin you’ll need one of the following browsers:


  • Chrome for Android Chrome for Android 66
  • Android Browser Android Browser 66
  • iOS Safari iOS Safari 11.3
  • iOS Safari iOS Safari 11.0-11.2
  • Samsung Internet Samsung Internet 6.2


  • Chrome Chrome 66
  • Chrome Chrome 65
  • Edge Edge 17
  • Edge Edge 16
  • Firefox Firefox 60
  • Firefox Firefox 59
  • Opera Opera 53
  • Opera Opera 52
  • Safari Safari 11.1
  • Safari Safari 11

Requirements for Premium Plugins

To receive update notifications for premium plugins, your host must support: