Why we don’t support old WordPress versions

For all sorts of reasons, some people have a problem with updating WordPress installs properly. I will state now that for both our free and premium plugins we do not support anything but the latest and the prior to last version. At the time of writing that’s WordPress 3.5 and WordPress 3.4. If you’re running anything else, we can’t help you. But mostly, I want to convince you to upgrade by dispelling all the reasons why you shouldn’t or “couldn’t” upgrade.

The top four reasons we hear:

#1: “my site / theme will break”

Usually followed by “and I don’t have the time to fix it”. Well, plan some time or hire someone. This week. Because if you’re on WordPress 3.1 or 3.2, it’s a matter of time before you’ll get hacked. At that time you’ll not have the luxury of “planning” the upgrade, you’ll just have to suck it up and deal with it. Prevent that from happening and upgrade.

#2: “our core modifications will be gone”

Your what? You do realize that if you were to tinker with the code of  say, Microsoft Word, Microsoft wouldn’t be helping you either? That’s exactly how it works with us. Our plugins work with WordPress, not with what you did to it. Remove your core modifications and turn them into plugins so they behave as expected by other plugins and then: update.

#3: “plugin x that we use won’t work anymore”

Well, you’ve got three options:

  1. contact that plugins developer and ask him to fix it;
  2. contact another developer and pay him to fix it;
  3. drop the plugin and start using another plugin.

#4: “I don’t need any of the new functionality”

WordPress is updated regularly, not just to add new functionality but to fix security issues too. Frankly, most people out there, probably including you, are not able to determine whether they need new functionality. WordPress 3.4 and 3.5 added API’s for developers that plugins that you’re using might want to use, not upgrading makes those plugins function less, or not at all.

Conclusion

In short: upgrade. I know some developers out there are saying that we can’t “require” people to upgrade, well, I disagree. He compares it to Apple not forcing you to buy a new Mac when it breaks. The difference there is that we’re not talking about hardware. We’re talking about software. Apple regularly asks you to upgrade your system to fix battery issues or other issues.

In the end, it’s an economic decision: I’m not going to spend valuable support and development time on a minority that doesn’t want to upgrade, at the cost of not developing new features or fixing bugs for current versions of WordPress. So, if you want to use our plugins, stay current!

Tags:


Yoast.com runs on the Genesis Framework

Genesis theme frameworkThe Genesis Framework empowers you to quickly and easily build incredible websites with WordPress. Whether you're a novice or advanced developer, Genesis provides you with the secure and search-engine-optimized foundation that takes WordPress to places you never thought it could go.

Read our Genesis review or get Genesis now!

23 Responses

  1. Martin MacDonaldBy Martin MacDonald on 7 March, 2013

    #6: We love leaving our sites vulnerable to automated hacking by rogue bots travelling the internet – without updating wordpress how do we make sure our sites are unsafe?

  2. David ArtissBy David Artiss on 7 March, 2013

    I totally, 100%, agree. I’m about to update one of my plugins to have a minimum WP installation of 3.3 and I suspect all of the above arguments will be in use.

    However, I also run numerous sites on WordPress and would never want to run them on such a back-level for precisely the reasons you give.

    David.

    • David ArtissBy David Artiss on 7 March, 2013

      Forgot to say… with regard to point 3, if anybody is not upgrading due to an abandoned, out-of-date plugin that they use, please get in touch – I’m looking at picking up such plugins and bringing them up-to-date.

      You see, once less reason to not upgrade ;)

  3. menachem rosenbaumBy menachem rosenbaum on 7 March, 2013

    you can always tell them that just like they don’t upgrade there site they don’t need to upgrade the plugin. Or then can go looking for an old version of the plugin.

  4. Robert AbelaBy Robert Abela on 7 March, 2013

    Couldn’t have said it any better!

    Many people do not realize how dangerous it can be not to upgrade WordPress. It can destroy your business reputation and yes WordPress websites do get hacked.

    In the last couple of months it happened to Reuters and Mastercard, 2 big corporations.

  5. Thierry ClermontBy Thierry Clermont on 7 March, 2013

    I always take time to sensitize my customers on the danger not to carry out the updates of WordPress. Hacking is a big problem.

  6. Carl HancockBy Carl Hancock on 7 March, 2013

    This should be standard policy for all theme and plugin developers.

  7. w0ngsimp4ngBy w0ngsimp4ng on 7 March, 2013

    Because they are still comfortable with old versions. But not security.

  8. RiffNinjaBy RiffNinja on 8 March, 2013

    Makes perfect sense to me! Thanks for your great plugins, I use them on all my sites.

  9. chrisBy chris on 8 March, 2013

    i 100% agree update update update.

  10. Tisha OehmenBy Tisha Oehmen on 8 March, 2013

    So true! There really is no excuse for not running current versions.

  11. rxbbxBy rxbbx on 9 March, 2013

    Developers of WP are always a step behind. When a new version comes hackers already know the leaks. This is with all software and scripts. Updating makes it only difficult for the amateurs and the older bots.

    Database, php or only static html. Server setting issues etc etc. People can hack all sites if they want.

    • Jason ParsonsBy Jason Parsons on 12 March, 2013

      Those old bots are the things you are trying to avoid. A dedicated attack is very unlikly and is a business/security case of it’s own.

      Getting hit by an old bot, ametur or worst of all, someone looking for very easy targets on the other hand nearly aproches certainty with time if you leave yourself unsecure long enough.

      That exploit will of course vary between nearly harmless to client damaging, but the cost of upgrading should be insugnificant compared to it regardless.

  12. FAT MediaBy FAT Media on 10 March, 2013

    Yoast hits the nail on the head yet again. If more developers took the same approach, 3 our of 4 of those issues wouldn’t even be issues in the first place.

    There’s really no excuse for avoiding updates. Unless you enjoy being hacked on a regular basis, UPDATE ALL THE THINGS.

  13. JamesBy James on 11 March, 2013

    You need to create a post to explain this?

  14. Madhav TripathiBy Madhav Tripathi on 11 March, 2013

    People have many reasons. Many people still using old WordPress versions. But now they have a forceful reason to update old WP version to latest.

  15. Matthew RuddyBy Matthew Ruddy on 13 March, 2013

    Completely agree. In recent plugin versions I’ve gone as far as requiring WordPress 3.5. More-so because backboneJS has been included with it (which I’ve used).

    However, there is an inherent fear of upgrading WordPress. Especially from users who don’t really know what to do when it all goes wrong.

    It’s the same for all software. Not everyone keeps them up to date. Until one day, years later, they do, and setups get destroyed. It’s not explicit to WordPress. Unless WordPress implements some sort of automatic background updating, kind-of like Google Chrome, it’s always going to be a problem.

  16. Mark D. AlbinBy Mark D. Albin on 17 March, 2013

    We always update our customers WordPress blogs when updates are available.

Trackbacks