An often made mistake by WordPress developers is to use to generic function and class names. For instance, if you’re building a plugin to do with YouTube, using a class name “Youtube” is bound to cause issues: if a user has multiple plugins dealing with Youtube, he or she could very well end up with two plugins that have a class Youtube, which would immediately cause a crash. The only way of fixing that would be to remove either of the two plugins.
The best thing to do in these cases is to use one or more classes for your plugin, and to use a namespace for these. So, for instance, a class called “YoastYoutube” instead of “Youtube”. One of the benefits of using a class is that the function names within that class can be short and concise and need not be namespace. So you could have a
function get(), within that class, and it would never break anything.
This is also valid for other instances where your chosen names might collide: custom taxonomies and custom post types, widget names and also specific hooks for actions and filters that you add to your plugin or theme.